--/--/--

スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

2007/09/02

端末で日本語打ちつづけると落ちる不具合

ここ(ubuntu-jpの中の人のIRCログっぽい)では対策あげたよって書いてあったんだけど、発生した。

上記のリンクで<jkbys> archive.ubuntulinux.jp に入れたので、upgradeすれば入ると思いますとあったので、

grep archive.ubuntulinux.jp /etc/apt/sources.list

してみたところ、

# deb http://archive.ubuntulinux.jp/ubuntu-ja edgy/
# deb http://archive.ubuntulinux.jp/ubuntu-ja edgy-ja/
deb http://archive.ubuntulinux.jp/ubuntu-ja edgy/
deb http://archive.ubuntulinux.jp/ubuntu-ja edgy-ja/

よくわからんけど何故か edgy edgy-ja がコメントアウトされてるにも関らず、同じものが有効になっている。しかも今走っているこの ubuntu は feisty だし。

とりあえず archive.ubuntulinux.jp に対策があがっているということなので

sudo apt-get update
sudo apt-get upgrade

してみるも、当然アップグレードは無し。今まで何回もアップグレードやってるんだから、これで解決するならとっくにしてるはずだし当然の結果。

なので、怪しいと思われる箇所を、下記のように書き換えてみる。

# deb http://archive.ubuntulinux.jp/ubuntu-ja edgy/
# deb http://archive.ubuntulinux.jp/ubuntu-ja edgy-ja/
deb http://archive.ubuntulinux.jp/ubuntu-ja feisty/
deb http://archive.ubuntulinux.jp/ubuntu-ja feisty-ja/

ほんで

sudo apt-get update
sudo apt-get upgrade

すると

> sudo apt-get upgrade
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています                
Reading state information... 完了            
以下のパッケージは保留されます:
  libtomoe-gtk0 ubuntu-desktop-ja
以下のパッケージはアップグレードされます:
  anthy evolution-data-server evolution-data-server-common jd kasumi
  language-pack-gnome-ja-base language-pack-ja-base lha-sjis libanthy0
  libcamel1.2-10 libebook1.2-9 libecal1.2-7 libedata-book1.2-2
  libedata-cal1.2-6 libedataserver1.2-9 libedataserverui1.2-8
  libegroupwise1.2-13 libexchange-storage1.2-3 libtomoe0 libvte-common libvte9
  libx11-6 libx11-data python-vte scim-anthy scim-tomoe tomoe-dic
  ubuntu-ja-setup-helper unzip

お、なんか scim-anthy とかそれっぽいのが入ってる。ストライクの予感。

とりあえずちょびっと使ってみたけど、今のところは再発していない。

ちなみにこの ubuntu、edgy から feisty にアップグレードしたんだけど、なんで自動的に edgy edgy-ja のところが書き換わっていなかったのかが不思議。コメントアウトはちゃんとされてるのに。

スポンサーサイト

comment

post




上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。